Home Portal

Skip to end of metadata
Go to start of metadata

License Agreement

The article presents the features available in the Premium plan of XTRF Language Business Platform. Please keep in mind that your access to the described options might be limited due to your license agreement. If you would like to change your plan of XTRF Language Business Platform and gain access to the additional features, contact your XTRF Customer Success Manager.

 

Target audience: Project Managers

 


 

 

 


 

Overview

 XTRF Language Business Platform is a powerful tool to automate your projects including full information management about the files and notifications coming from your partners: clients and vendors. Automatic document management accelerates your project where the Project Manager can streamline the information flow through the vendors activities. As a result, you need to spend much less time on coordinating the communication between all people participating in the projects, and the translation process requires less effort even while translating documents to many languages. Within XTRF Platform you can create even very complex projects where clients can specify their requirements and where vendors can work in the most efficient way. This article describes how to provide basic information for your project and include all data in a functional specification. You are guided on how to prepare a project where the file is supposed to be translated into two languages. If you require a more complex solution, you can also apply the description presented below, however it might require additional involvement to repeat the steps from a given section.

 

Before Reading a Tutorial

  • The steps without any marking are mandatory to perform because they ensure carrying on a proper function of the Home Portal.
  • The steps marked with the (Optional) label give you information about settings useful for you in terms of fulfilling specific requirements for your projects, but if you skip them it will have no negative effect on the function of the Home Portal.

 

 

 

Create Your Project

To put your project up on XTRF Platform, you need only to start your work. Let's create one!

 

 

I. Enter the Project's Basic Information

The very first step of creating a project is providing basic information, such as the name of your project, what kind of activities the project should include, and who is going to manage the project at your company. This triggers the whole process of creating a project.

 

Click to perform the steps...

To trigger the process of creating a project, perform the following steps:

 Sign in to the Home Portal of XTRF Platform.
 Click the Projects Module icon.
 Click the Create button.
 

Select for which client a project is processed by clicking the Select Client button:

    1. In the Select Client Price Profile pop-up window find client with a price profile you are interested in:
      • You can select a price profile from a list on the right-hand side.
      • If you have a lot of entries on your Client Price Profile list, you can use the search on the left-hand side to narrow the displayed entries.
    2. When you select the required price profile the Select Client Price Profile pop-up window closes and the data are provided in the Client field and the Client Price Profile section.

 

Creating a Client

If you click the Create Client button, you are redirected to the Clients module where you can add a client to your database. For more information how to add a client in the Home Portal go to the Adding a New Client Profile to the Database article. 

 

From the Contact Person drop-down menu select a person to whom you should receive the project's ready files.

Client as the Individual

 If in the client's profile the client e-mail address is given also as the address where the target language should be sent to, this client profile appears also as the contact person profile.

 (Optional) You can specify which template of the project should be applied for a given one in the Project Template section.
 

(Optional) In the Name field provide a name for this project. For this example, the project's name is Project with Task Workflow.

 

From the Project Manager drop-down menu select the user at your company who is responsible for this project. By default, the system automatically selects the currently signed-in user.

 

 (Optional) From the Workflow drop-down menu select a Workflow Definition you want to use. You can select a workflow defined by default in the Home Portal or this one you have created. This option accelerates the process of creating the project because in the Workflow Definition the jobs are already defined. Mind that in this tutorial the Translation workflow is selected.

 

Workflow Definitions

You can define a custom workflow with tasks and jobs oftenly preformed at your company. To learn how to do that, go to the following articles:

  (Optional) From the Specialization drop-down menu select a qualification such as a knowledge of medicine or law terms required for this project. In the picture the Economy is selected.
 In the Created on field you need to provide when the project is set. By default, XTRF Platform sets the current date and time automatically.
 

In the Start Date and Time section decide when the entire project should begin.For example, the 2015-02-09 13:27 data is set.

  • Manually enter the date in the appropriate date format set in the System Configuration.
  • Click the   icon  and select the date from the calendar. 
 

(Optional) In the Deadline section decide when the files should be completed and delivered to your client. For this example, 2015-02-13 13:27 is set.

  • Manually enter the date in the appropriate date format set in the System Configuration.
  • Click the   icon and select from the calendar. 
 

Click the Save button at the bottom of the Create Project display. You have just set up a project with basic information.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

II. Select the Language Combination
One of the most important things while setting up a project is defining the languages of your source and target files. This can be done in the Create Project Language Combination display.

 

 

Click to perform the steps...

To select the language combination, follow the steps:

 

In the Mode section select the radio button of the method which you want to use for your translation process:

  • One to Many option: You can trigger the workflow where you want to process your files from one language to many languages
  • Many to One option: You can run the process where files are performed from many languages, but the output files are delivered only in one language.

For example, the One to Many radio button is selected.

 From the Source Language drop-down menu select the language the client wants to provide you the source files.
 In the Target Language mutli-selection field add the language(s) of the finished material. Double-click on a language in the Available Items list in order to add it to the Selected Items list.  For example, German [DE] and French [FR] are selected. 
 

Click the Create button. You have just defined the source and target languages as the language combination in the newly created item.

 

 

Settings in the Project Language Combination Display

You can find the full descriptions of the configurable options in the Add Language Combination - Project article. 

 

 

 

III. Create a Task
Each project contains one or a set of tasks associated with a given language combination. You need to create a task for each language combination because at the lower level each task contains jobs which are assigned to proper vendors. This results in each vendor performing a given job such as translation or editing for a given language. It also means that you manage the project from the task level where every single task is a set of services purchased by your client. 

 

 

Click to perform the steps...

To create a task for a given project, perform the following steps:

Create Task Display

 If you have added multiple language combinations, the data are displayed for the last language combination.

 (Optional) Provide all data in the Main Data tab. All required settings are already set up because the information is transferred from the recorded item's data. 
 

Click the Save button. The task appears below its associated language combination in the left-hand panel.

 

 

How Many Tasks Can I Create?

You can create as many tasks as you need for your project.

Settings in the Task Display

The guide outlines the basic scenario of creating a project. For full descriptions of the configurable options go to the Task Display - Project article. 

 

 

 

IV. Upload a Source File
When you have created the tasks for your project, you need to attach proper files to them. It might happen that you can upload the same files for all language combination or only for some of them. You can upload single files in different formats or you can zip your files into one and attach this package to your task.

 

 

Click to perform the steps...

To upload the source file for a given task in your project, perform the steps:

 

On the left-hand side select a task to which you want to upload the files. The selected item appears in boldface.

 Click the icon.
 Go to the Workflow Graph tab.
 

In the Workflow Graph tab you can find a diagram presenting your translation process. Select the files item in the Task Input graph box.

 Click the Add button in the Task Input graph box.
 

The Upload File pop-up window appears.

    1. Click the Add files... button in the Upload File tab. The file manager window available on your local machine appears.
    2. Select the files you want to upload to the XTRF's project: you can attach one or more files. The names of the attached files should appear in the Upload File pop-up window.
    3. Define what kind of files set you are uploading from the Bundle drop-down menu. The types of bundles must be defined while creating a Workflow Definition.
    4. Click the Save button.

 

Maximum Size of the Source Files

You can upload files which size is up to 100 MB. If you have larger files the recommended way of uploading them is using the FTP connection. For more information go to the FTP - Advanced Configuration article.

.ZIP Files

You can upload files in the ZIP format to your project. In that case you need to remember to select Unzip checkbox in the Upload File pop-up window. When you close the Upload File pop-up window the system automatically decompresses the ZIP file, and the files are individually displayed in the Task Input diagram box.

  The Upload File pop-up window closes. You can see the uploaded files in the Task Input diagram box.

 

 

Different Source Files for Different Language Combinations

If you need to upload different source files for different language combinations included in the project, you need to repeat the steps in this section for tasks which have different source files. Otherwise, you can copy a task with its source files for other language combinations. The next section in this tutorial shows how to copy a task in the project.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

V. Select a Vendor for an Activity

Selecting vendors for the activities means that you need to assign them to different jobs, for example a translator with German specialization should be assigned to perform the German translation of a given document. This exemplifies the scenario where vendors do jobs typical for their professions in the localization process. The jobs constitute each task for a given language combination and might be done by different vendors. This guide shows a project with two tasks, each of them containing only one translation job. Assigning a vendor to a job is a mandatory step in the process of creating a project in the Home Portal. In the following scenario, you are going to assign a vendor manually, which means that you have already contacted your vendor who has accepted to do the offered job. 

 

 

 

Asking Vendors If They Can Undertake a Job

If you want to ask your vendors if they are available to start working on a job, you may send them availability requests. If any of them picks up a job, you will get a notification from this person. To learn how to offer a job to your vendors, go to the Assigning a Vendor within Availability Requests article.

 

 

Click to perform the steps...

To assign a vendor to a given activity in your project, follow the steps:

 

On the left-hand side select a task which you want to assign a vendor to. The selected item appears in boldface.

 Click the icon.
 

 In the Workflow Graph tab click the Select Vendor button on the desired job diagram box. The Job pop-up window appears.

 

Opened Job Status

Be aware that the jobs status should be set to Opened to be able to assign a vendor to a job.

 

In the Job pop-up window select a vendor you want to assign to a given job clicking the Select Vendor button. List of the vendors defined in the Home Portal appears.

    1. Select a vendor:
      • Select a vendor you want to do a given job by double-clicking their price profile on the list.
      • You might want to narrow the displayed vendor entries using a search filter. Next, double-click a vendor to assign this person to a job.
    2. Click the icon in the Deadline section. The calendar pop-up window appears.
      1. Select a month and year as a deadline date for your project.
      2. Select a day as a deadline date for your project. The calendar pop-up window closes.
 

Click the Save button. The Job pop-up window closes. The vendor is assigned to a workflow job, therefore the status of a job is set to Accepted.

 

 

More Than One Job in a Task

If you have more than one job in your task for a given language combination you need to assign a vendor to each single job.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

VI. Add a Payable

When you have created the project where the vendors have been assigned to all jobs, you need to take care of the financial statements of the project. First, you need to prepare individual charges paid to the vendor for the job. In XTRF Platform the vendor financing is called a payable. For each single job you need to prepare a payable which includes charges, discounts, and surcharges. 

 

Click to perform the steps...

To add a payable for a given job in the project, follow the steps:

 

On the left-hand side select a task which you want to add a payable to. The selected item appears in boldface.

 Click the  icon.
 Go to the Jobs tab. In the Jobs tab you can find all jobs which are supposed to be performed in the project. In this case, only the translation job is displayed.
 Click the  icon for a given job. You are redirected to the last visited tab for the selected job.
 

Go to the Payables tab.

 

Click the Add Payable button. The Job Payable pop-up window appears: provide the following data:

    1. Click the Job Payable radio-button in the Payable Type section.
    2. From the Calculation Unit drop-down menu select the unit to calculate the cost for the vendor's service, for example the source word.
    3. Provide the value of the rate in the Rate Value field.

      Vendor's Price Profile

      If you already have configured the price profile for your vendor, this value is set up automatically. To learn more about the price profiles for your vendors go to the Managing the Vendor's Price Profile - draft article.

    4. In the Quantity section provide the amount of a material processed by the vendor. You can do it as follow:
      • Provide the number manually
      • Click the Import from... button to get the number from the file statistics.
    5. (Optional) Leave some additional information in the Description field.
 Click the Save button. The Job Payable pop-up window closes.
 (Optional) If you want to provide some discounts or an additional charge you need to click the Edit button in the Discounts/Surcharges row in the table.
 

You have added the payable for the translation job for a given vendor. If you hover your mouse over the newly added payable you can see all details about the financial entry.

 

 

The Payables Tab Description

For more information about the options available for the Payable tab for a given job go to the Payables - Job - Project article. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

VII. Add a Receivable

The last step before you start the jobs is adding a receivable in a project. Adding a receivable means that you want to charge the individual for each of the task jobs and, if required, include or remove discounts or surcharges. In the Receivable tab you can override the minimum charge defined in the client's price profile and use the task's lower total value instead. Note that the financial details provided in the receivable will be transferred into the invoice document when it comes to close a project.

 

 

Click to perform the steps...

To add a receivable for your client to charge for the desired service, perform the following steps:


 

On the left-hand side select a task which you want to add a receivable to. The selected item appears in boldface.

 Click the  icon.
 Go to the Receivables tab.
 

Click the Add Receivable button. The Task Receivable pop-up window appears. Provide the following data:

    1. Select the Task Receivable radio button in the Receivable Type section.
    2. Select a service which you want to charge your client for. In the example, the translation job is selected.
    3. Select the unit to charge your client for the service from the Calculation Unit drop-down menu, for example the source word.
    4. Provide the number of your rate in the Rate Value field.

      Client's Price Profile

      If you already have configured the price profile of your client, this value is set up automatically. To learn more about the price profiles for your clients go to the  Managing the Client's Price Profile article.

    5. In the Quantity field provide the amount of material to be processed. You can do it as follows:
      • Provide the number manually.
      • Click the Import from... button to get the number from the file statistics.
    6. In the Discount/Surcharge section click the Edit button to define the discount or surcharge for your client.
 Click the Save button. The Task Receivable pop-up window closes.
 

 You have added the receivable for the given task. If you hover your mouse over the newly added receivable you can see all details about the financial entry.

The Receivables in the Project

Please bear in mind that you need to define at least one receivable in the project.

 

 

The Receivables Tab Description

For more information about the options available for the Payable tab for a given job go to the Receivables - Task - Project article. 

 

 

 

VIII. Copy a Task

For each language combination you need to create a task. If you have created one task, instead of creating the next ones and manually reentering all information, you can copy an existing task in the project. While copying the task, you specify which information you want to duplicate in the new task or provide data specific only to the task being copied. Note that you can copy provided information, but even more, you make a copy of the input files uploaded in the original task. In addition, while copying a task, you can set up a different workflow of the vendors' activities. The receivables and payables can also be propagated.

 

Click to perform the steps...

To copy the existing task and set up the options appropriately, follow the steps:

 In the Task display click the Copy Task button.  The new display with the duplicated data of the existing task appears.
 Select which the existing task should be copied from the Task drop-down menu.
 

In the Languages multiple selection field, decide which language combination the new task will be created for. Double-click the desired language combination in the Available Items list. Items in the Selected Items list represent the language combinations which will receive a copy of the task.

 

Multiple Tasks Created with One-Click

If you add multiple languages to the Selected Items list, a task is created for each. Let's assume that you have a project with one task: 2013/123/1. You want to make a copy of this task for English [EN] >> French [FR] and English [EN] >> German [DE]. After you click the Copy Task button, the system creates the following tasks:

  • 2013/123/2 for English [EN] >> French [FR]
  • 2013/123/3 for English [EN] >> German [DE]
 (Optional) You can select which information will be copied to the new task such as vendors, payables, or input files.
 

Click the Copy Task button.

 

You can see your newly copied task under its selected language combination.

 

 

The Copy Task Settings

For full descriptions of the settings in the Copy Task display, read the Copy Task - Project article.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

IX. Start the Workflow
When you have planned the work for a given project by creating all tasks and assigning the vendors, you can start to execute the jobs. This is a one-click action in the Workflow Graph tab.

 

 

Click to perform the steps...

To start the workflow for your task in the project, follow the steps below:

Include - Starting a Workflow
 

On the left-hand side select a task to which you want to start. The selected item appears in boldface.

 Click the  icon.
 Go to the Workflow Graph tab.
 

In the Workflow Graph tab you can find a diagram presenting your translation process. Check if the job status is set to Accepted. In other words, the Accepted status means that the vendor has accepted the offered job and enables you to start your project workflow for a given task.

Job Statuses

 Mind that if you have more than one job in the workflow, a vendor should be assigned to at least the first job to start the process, which means the job status should be set to Accepted.

 

 Click the Start Workflow button in the left-bottom corner of the workflow graph box.
 

 The status of the job has changed to Started:

 

Starting All Workflows with One-Click

If you have created all tasks with their jobs, you can start all workflows at once. You only need to click the Start All Workflows button which is located just below the explorer tree with your defined tasks on the left-hand side. Mind that the Start All Workflows button is only available in the Project tab.

 

 

Workflow Graph Detailed Description

For more information about the options available in the Workflow Graph tab for a given task go to the Workflow Graph - Task - Project article. 

 

 

 


Tips and Tricks

To find some hints on how to change settings for a project, go to the FAQ page: Can I Make a Project File Visible Only Internally?