Home Portal

Skip to end of metadata
Go to start of metadata
 

License Agreement

The article presents the features available in the Premium plan of XTRF Language Business Platform. Please keep in mind that your access to the described options might be limited due to your license agreement. If you would like to change your plan of XTRF Language Business Platform and gain access to the additional features, contact your XTRF Sales representative.

Target audience: Developers

 


 

 

 


 

In XTRF Platform you can incorporate a set of Document Templates which are built with the BIRT-4 software project. This set contains the Document Templates which are the most commonly used in the translation process, for example the template of quote confirmation or customer invoice document. However, you might want to customize the available templates to finally get the personalized set of documents adjusted to your and your partners needs. This requires to get familiar with the Eclipse environment and have knowledge of incorporating information from the delivered libraries package . The purpose of this article is to show you how to set up your Report Design Project in Eclipse and make a desired Document Template ready to get modified. Please bear in mind that after all changes haven been made, you need to add the customized Document Templates to XTRF Language Business Platform.

 

 

 

 

 

 

 

Before Reading a Guide

  • The steps without any marking are mandatory to perform because they ensure carrying on a proper function of the Home Portal.
  • The steps marked with the (Optional) label give you information about settings useful for you in terms of fulfilling specific requirements for your projects, but if you skip them it will have no negative effect on the function of the Home Portal.

 

Semantics in Terms of Document Templates

In the article the following semantics is applied regarding the Business Intelligence and Reporting Tools (BIRT) version used to prepare Document Templates :

 

Link to the external page

Customize a Document Template

The delivered XTRF Document Templates can be adjusted to your requirements in terms of:

  • Information which is displayed in a document
  • Style of a document.

In the following scenario you can find how to set up your Eclipse environment, run your Report Design project, and apply changes to the existing Document Template.

I. Download the Files Package

To get a package with a default set of Document Templates prepared with BIRT-4 version and *.rptlibrary libraries which are necessary to use reporting environment in BIRT, perform the following steps:

 

Go to the XTRF repository location that was provided by us.

Gaining Access to the XTRF Repository

Mind that the XTRF repository is password-protected. To gain access to the XTRF repository, please contact the XTRF Support Team to get the current password.

 

 

 

 

 From the XTRF repository download the templates_2015_birt4.zip package and store it on your local machine.
 Extract the templates_2015_birt4.zip package locally. The default folder name after unzipping the package is templates_en_2015_birt4.
 

On your local machine go to the \templates_en_2015_birt4\1.0.x\PDF folder; where x means the version of the downloaded package, for example 1.0.13. You should see the following set of *.rptdesign files:

 

 

 

BIRT-4 Document Templates

From the XTRF repository you can get the thirteen Document Templates created within the BIRT-4 version. These templates are the most commonly used in XTRF Platform in the business translation process with your partners. You can find there ready-to-use templates for invoices or quote confirmation documents. All templates are prepared in English, although they can be easily localized for a given language available in XTRF Platform.

 

Libraries in BIRT

Besides the set of Document Templates you can find a package of *.rptlibrary files in the \templates_en_2015_birt4\1.0.x\LIBS folder; where x stands for the version of the downloaded package, for example 1.0.13. The files are the XTRF library files within customized reporting components which are used in XTRF Platform. In the libraries the most commonly used functions and report items are encapsulated to reduce time spent on redesigning template layout. This enables you to use the library reporting components at any time and also share them with other people working with BIRT. The picture below presents a list of customized BIRT libraries included in the templates_2015_birt4.zip package to comfortably apply schemas in your Document Templates:

 

 

II. Prepare the Eclipse Environment

To work on the Document Templates and adjust them to your needs, first you need to download the appropriate Eclipse package, unpack it and set up your Eclipse environment on your local machine. The following steps guide you how to do it:

 

Go to the XTRF repository that was provided by us.

Gaining Access to the XTRF Repository

Mind that the XTRF repository is password-protected. To gain access to the XTRF repository, please contact the XTRF Support Team to get the current password.

 

 

 

 

 From the XTRF repository download the eclipse-birt4.zip package and store it on your local machine.
 Extract the eclipse-birt4.zip package locally. The default folder name after unzipping the package is eclipse.
 

On your local machine go to the newly unpacked \eclipse\ folder. You should see the files as follows:

 

Click the eclipse icon to run your Eclipse environment. The Workspace Launcher pop-up window from the Eclipse software project appears.

 

Select a workspace for your project, for example yourworkspace. The Java EE -Eclipse window appears.

 

Close the Welcome tab in the Java EE -Eclipse window. The Java EE -Eclipse window appears.

 

Select the Window > Show View > Other... in the Java EE -Eclipse menu. The Show View pop-up window appears.

 

In the explorer tree of the Show View pop-up window:

    1. Select the Report Design > Property Editor subbranch.
    2. Click the Ok button.
 

You have just prepared your Eclipse environment:

III. Run Your Report Design Project

In Eclipse you can use project perspectives to structure your files and simultaneously have access to project management tools. It enables you to conveniently edit the selected Document Template and simplify the process of deploying it. In this section you are going to learn how to get your desired Document Template prepared for customization within the Report Design perspective:

 

Select the File > New > Project in the Java - Eclipse window. The New Project pop-up window appears.

 

In the New Project pop-up window:

    1. In the explorer tree select the Business Intelligence and Reporting Tools > Report Project subbranch.
    2. Click the Next button. You are redirected to the Report Project display.
    3. Provide the name of your project in the Project name field, for example Document Templates.
    4. Unselect the Use default location checkbox - it enables you to define a location of your report project.
    5. Click the Browse button. The file manager window available on your local machine appears.
      1. Select the \templates_en_2015_birt4\1.0.x\ folder - you can find it in the unzipped \templates_en_2015_birt4\ folder containing the *.rptlibrary and *.rptdesign files; where x stands for the version of the downloaded package, for example 1.0.13.
      2. Click the Ok button. The file manager window closes.
    6. The selected location of the files appears in the Location field in the Report Project display.
    7. Click the Finish button. The New Project pop-up window closes.

Open Associated Perspective Pop-up Window

It might happen that when the New Project pop-up window closes, the Open Associated Perspective? pop-window appears asking you if you want to open the perspective in this moment. Click the Yes button to continue opening your report project.

 

 

 

You have just opened the report project in Eclipse within the Document Templates you have downloaded from the XTRF repository.

 

Click the PDF branch in the Navigator panel in the Report Design in Eclipse. You can see the set of XTRF Document Templates:

 

 

Link to the external page

IV. Edit the Document Template

When your Eclipse environment is set up, you are able to modify both, the content of displayed information and the layout of the Document Template. The very first step is accessing the required Document Template in the editable format in the Eclipse project; then, you can customize the desired Document Template.

In the Navigator panel select the Document Template you are about to modify. In this guide the CustomerQuoteConfirmation.rptdesign file is selected. The Customer Quote Confirmation Document Template is displayed. You can modify the selected Document Template using settings delivered within Eclipse.

IV.I. Modify the Content of Your Document Template

To personalize the content of the Document Template you can do it within the embedded *.rptlibrary libraries. Each Document Template encapsulates particular libraries what enables you to simply drag and drop an item to add it to the report. First of all, you need to know which libraries are used for each template; next, you can use the report items available in the known libraries to change the content of a given Document Template. The following steps present you how to add a report component to the Customer Quote Confirmation Document Template:

Document Templates Common Library

 Each Document Template which you have downloaded from the XTRF repository encapsulates the commonLib.rptlibrary file. Therefore, you can use the report items delivered within this library in each of the Document Templates.  

 

 

 When you have edited the Customer Quote Confirmation Document Template in the Eclipse window, click the XML Source tab. You can see the Document Template as the .XML file. 
 

Find the libraries property in the given DocumentTemplate.rptdesign file. You can find out which libraries are encapsulated for the Document Template.  In this guide the CustomerQuoteConfirmation.rptdesign file is given as an example: you can see that the following libraries are added:

  • The projectConfirmationLib.rptlibrary file
  • The commonLib.rptlibrary file.

CustomerQuoteConfirmation.rptdesign
 

When you have defined which libraries are used, you can verify which report items are embedded in these libraries. To do so, go to the Resource Explorer tab. You can see all the encapsulated libraries in the LIBS folder.

 

In the Resource Explorer tab expand a given *.rptlibrary file, for example the commonLib.rptlibrary.

 

 In the Resource Explorer tab expand the Report Items subbranch. For example, you can see the report components embedded in the commonLib.rptlibrary file.

 

 

 

Accessible Report Itmes

The report components which you can use for a given Document Template are these ones which are embedded in the libraries found in the previous steps. In the following example you have found the libraries: commonLib.rptlibrary and projectConfirmationLib.rptlibrary files. It means that the components available under the Report Items subbranch for the commonLib.rptlibrary and projectConfirmationLib.rptlibrary files can be used. The components from the other libraries are unavailable.

 

 Select the report component from the Report Item subbranch: drag and drop it to the displayed Document Template.
 

Select the File > Save in the Report Design menu to store all changes you have made in the Document Template.


IV.II. Modify the Document Templates Properties

Modifying the Document Template properties means changing the layout of the template. You can do it on the spot using the settings available in the Eclipse environment. The following steps instruct you how to find the settings used to change the design of the document layout:

 

(Optional) To change the properties of your Document Template, follow the steps:

    1. Go to the Property Editor tab at the bottom of the selected Document Template Report Design window.
    2. In the Properties tab you can find the list of all properties used to adjust the Document Template to your needs.

      General Section in the Properties Tab

      In the Properties tab you can find all settings which might be used to redesign the look and feel of your Document Templates such as styles, paddings, or borders.

 

 

 

Select the File > Save in the Report Design menu to store all changes you have made.

Make Your Customized Document Templates Available in XTRF Platform

When you have saved all changes made in the Document Templates, you need to upload them to XTRF Language Business Platform. To find out how to do it, read the Adding BIRT-4 Type Document Templates article.

 

 


Tips and Tricks

To find more information on the Document Templates topic, go to the following articles:

 


  • No labels