Home Portal

Skip to end of metadata
Go to start of metadata
 

Target audience: XTRF Platform's users

 


 

 

If you use XTRF Language Business Platform as the application for your translation process the only requirements is to have installed and running Internet browser.

 

It is strongly recommended to use the latest stable and tested version of the Internet browser that all XTRF Platform's features can work correctly.

 

 

 

 

 

 

This article describes the Internet Browsers required to use the XTRF Language Business Platform

Internet Browsers

With XTRF Language Business Platform the following browsers are supported:

BrowserVersionsLink to the Browser Page
Google Chrome50.0 and higherhttps://www.google.com/chrome/
Mozilla Firefox52.0 and higherhttps://www.mozilla.org/firefox/new/
Opera34.0 and higherhttps://www.opera.com/